*PHP 4.3.9, 4.4.2 veya 5.0.4 kullanmayın. Bu sürümlerin kurulumunda bazı hatalar verdiği biliniyor. PHP 4.4.x için Zend Optimizer 2.5.10 sürümünün de ciddi hataları olduğu biliyor ve yeni sürümünün yüklendiğine dair sunucu sahibinizden onay almanız gerekiyor. Joomla! 1.5.15 ve üzeri sürümler PHP 5.3 ile uyumludur. Fakat OpenID kütüphanesi henüz PHP 5.3 ile uyumlu değildir.

** Joomla henüz MySQL 6.x ile uyumlu değil.
*** SEO URL kullanacaksanız, Apache mod_rewrite eklentisini kurmak zorundasınız.
**** Joomla, Apache ile uyumlu çalışmaktadır. Fakat Microsoft IIS ile de çalışabilmektedir (resmi olarak desteklenmiyor). ISS kurulumunuza bağlı olarak aşağıdakilere ihtiyacınız olabilir: